Race Condition Affecting golang-1.7 package, versions <1.7.4-2+deb9u4


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.11% (88th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-GOLANG17-1536775
  • published6 Aug 2021
  • disclosed8 Aug 2021

Introduced: 6 Aug 2021

CVE-2021-36221  (opens in a new tab)
CWE-362  (opens in a new tab)

How to fix?

Upgrade Debian:9 golang-1.7 to version 1.7.4-2+deb9u4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream golang-1.7 package and not the golang-1.7 package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

Go before 1.15.15 and 1.16.x before 1.16.7 has a race condition that can lead to a net/http/httputil ReverseProxy panic upon an ErrAbortHandler abort.

CVSS Base Scores

version 3.1