Arbitrary Code Injection Affecting golang-1.8 package, versions <1.8.1-1+deb9u1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
7.63% (95th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-GOLANG18-275328
  • published7 Feb 2018
  • disclosed7 Feb 2018

Introduced: 7 Feb 2018

CVE-2018-6574  (opens in a new tab)
CWE-94  (opens in a new tab)

How to fix?

Upgrade Debian:9 golang-1.8 to version 1.8.1-1+deb9u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream golang-1.8 package and not the golang-1.8 package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

Go before 1.8.7, Go 1.9.x before 1.9.4, and Go 1.10 pre-releases before Go 1.10rc2 allow "go get" remote command execution during source code build, by leveraging the gcc or clang plugin feature, because -fplugin= and -plugin= arguments were not blocked.