Information Exposure Affecting guacamole-server package, versions <0.9.9-2+deb9u1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.79% (57th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-GUACAMOLESERVER-1017019
  • published2 Jul 2020
  • disclosed2 Jul 2020

Introduced: 2 Jul 2020

CVE-2020-9497  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade Debian:9 guacamole-server to version 0.9.9-2+deb9u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream guacamole-server package and not the guacamole-server package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

Apache Guacamole 1.1.0 and older do not properly validate datareceived from RDP servers via static virtual channels. If a userconnects to a malicious or compromised RDP server, specially-craftedPDUs could result in disclosure of information within the memory ofthe guacd process handling the connection.

References

CVSS Base Scores

version 3.1