CVE-2005-1545 Affecting ht package, versions <0.8.0-3


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.21% (81st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-HT-317025
  • published14 May 2005
  • disclosed14 May 2005

Introduced: 14 May 2005

CVE-2005-1545  (opens in a new tab)

How to fix?

Upgrade Debian:9 ht to version 0.8.0-3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ht package and not the ht package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

Integer overflow in the ELF parser in HT Editor before 0.8.0 allows remote attackers to execute arbitrary code via a crafted ELF file, which leads to a heap-based buffer overflow.

CVSS Base Scores

version 3.1