Use of Externally-Controlled Format String Affecting irssi package, versions <1.0.7-1~deb9u1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.44% (84th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-IRSSI-350834
  • published6 Jan 2018
  • disclosed6 Jan 2018

Introduced: 6 Jan 2018

CVE-2018-5205  (opens in a new tab)
CWE-134  (opens in a new tab)

How to fix?

Upgrade Debian:9 irssi to version 1.0.7-1~deb9u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream irssi package and not the irssi package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

When using incomplete escape codes, Irssi before 1.0.6 may access data beyond the end of the string.