Out-of-bounds Write Affecting libebml package, versions <1.3.4-1+deb9u2


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.73% (77th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-LIBEBML-1071585
  • published10 Feb 2021
  • disclosed23 Feb 2021

Introduced: 10 Feb 2021

CVE-2021-3405  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Debian:9 libebml to version 1.3.4-1+deb9u2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libebml package and not the libebml package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

A flaw was found in libebml before 1.4.2. A heap overflow bug exists in the implementation of EbmlString::ReadData and EbmlUnicodeString::ReadData in libebml.

CVSS Base Scores

version 3.1