Out-of-Bounds Affecting librest package, versions <0.7.92-3


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.47% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-LIBREST-274790
  • published18 Aug 2017
  • disclosed18 Aug 2017

Introduced: 18 Aug 2017

CVE-2015-2675  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Debian:9 librest to version 0.7.92-3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream librest package and not the librest package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

The OAuth implementation in librest before 0.7.93 incorrectly truncates the pointer returned by the rest_proxy_call_get_url function, which allows remote attackers to cause a denial of service (application crash) via running the EnsureCredentials method from the org.gnome.OnlineAccounts.Account interface on an object representing a Flickr account.

CVSS Base Scores

version 3.1