Incorrect Default Permissions Affecting linux-4.19 package, versions <4.19.146-1~deb9u1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.4% (32nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-LINUX419-1013396
  • published25 Sept 2020
  • disclosed24 Sept 2020

Introduced: 24 Sep 2020

CVE-2020-26088  (opens in a new tab)
CWE-276  (opens in a new tab)

How to fix?

Upgrade Debian:9 linux-4.19 to version 4.19.146-1~deb9u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream linux-4.19 package and not the linux-4.19 package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

A missing CAP_NET_RAW check in NFC socket creation in net/nfc/rawsock.c in the Linux kernel before 5.8.2 could be used by local attackers to create raw sockets, bypassing security mechanisms, aka CID-26896f01467a.

CVSS Base Scores

version 3.1