Race Condition Affecting linux-4.19 package, versions <4.19.208-1~deb9u1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.31% (22nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-LINUX419-1730501
  • published3 Sept 2021
  • disclosed3 Sept 2021

Introduced: 3 Sep 2021

CVE-2021-40490  (opens in a new tab)
CWE-362  (opens in a new tab)

How to fix?

Upgrade Debian:9 linux-4.19 to version 4.19.208-1~deb9u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream linux-4.19 package and not the linux-4.19 package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

A race condition was discovered in ext4_write_inline_data_end in fs/ext4/inline.c in the ext4 subsystem in the Linux kernel through 5.13.13.

CVSS Base Scores

version 3.1