Improper Input Validation Affecting linux-4.19 package, versions <4.19.132-1~deb9u2


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.52% (40th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-LINUX419-598279
  • published10 May 2020
  • disclosed9 May 2020

Introduced: 9 May 2020

CVE-2020-12771  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:9 linux-4.19 to version 4.19.132-1~deb9u2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream linux-4.19 package and not the linux-4.19 package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

An issue was discovered in the Linux kernel through 5.6.11. btree_gc_coalesce in drivers/md/bcache/btree.c has a deadlock if a coalescing operation fails.

CVSS Base Scores

version 3.1