Integer Overflow or Wraparound Affecting mruby package, versions <1.2.0+20161228+git30d5424a-1+deb9u1


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.59% (85th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-MRUBY-278131
  • published17 Apr 2018
  • disclosed17 Apr 2018

Introduced: 17 Apr 2018

CVE-2018-10191  (opens in a new tab)
CWE-190  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Debian:9 mruby to version 1.2.0+20161228+git30d5424a-1+deb9u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mruby package and not the mruby package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

In versions of mruby up to and including 1.4.0, an integer overflow exists in src/vm.c::mrb_vm_exec() when handling OP_GETUPVAR in the presence of deep scope nesting, resulting in a use-after-free. An attacker that can cause Ruby code to be run can use this to possibly execute arbitrary code.

CVSS Base Scores

version 3.1