Out-of-Bounds Affecting netty-3.9 package, versions <3.9.9.Final-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
4.22% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-NETTY39-546861
  • published6 Feb 2020
  • disclosed31 Jul 2014

Introduced: 31 Jul 2014

CVE-2014-3488  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Debian:9 netty-3.9 to version 3.9.9.Final-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream netty-3.9 package and not the netty-3.9 package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

The SslHandler in Netty before 3.9.2 allows remote attackers to cause a denial of service (infinite loop and CPU consumption) via a crafted SSLv2Hello message.

CVSS Base Scores

version 3.1