Double Free Affecting opencv package, versions <2.4.9.1+dfsg1-2+deb9u1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.35% (84th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-OPENCV-293945
  • published10 Apr 2017
  • disclosed10 Apr 2017

Introduced: 10 Apr 2017

CVE-2016-1516  (opens in a new tab)
CWE-415  (opens in a new tab)

How to fix?

Upgrade Debian:9 opencv to version 2.4.9.1+dfsg1-2+deb9u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream opencv package and not the opencv package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

OpenCV 3.0.0 has a double free issue that allows attackers to execute arbitrary code.

CVSS Base Scores

version 3.1