Cryptographic Issues Affecting php7.0 package, versions <7.0.0-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
4.35% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-PHP70-386510
  • published22 May 2016
  • disclosed22 May 2016

Introduced: 22 May 2016

CVE-2015-8867  (opens in a new tab)
CWE-310  (opens in a new tab)

How to fix?

Upgrade Debian:9 php7.0 to version 7.0.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream php7.0 package and not the php7.0 package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

The openssl_random_pseudo_bytes function in ext/openssl/openssl.c in PHP before 5.4.44, 5.5.x before 5.5.28, and 5.6.x before 5.6.12 incorrectly relies on the deprecated RAND_pseudo_bytes function, which makes it easier for remote attackers to defeat cryptographic protection mechanisms via unspecified vectors.