Arbitrary Code Injection Affecting php-horde-util package, versions <2.3.0-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
42.9% (99th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-PHPHORDEUTIL-285782
  • published1 Apr 2014
  • disclosed1 Apr 2014

Introduced: 1 Apr 2014

CVE-2014-1691  (opens in a new tab)
CWE-94  (opens in a new tab)

How to fix?

Upgrade Debian:9 php-horde-util to version 2.3.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream php-horde-util package and not the php-horde-util package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

The framework/Util/lib/Horde/Variables.php script in the Util library in Horde before 5.1.1 allows remote attackers to conduct object injection attacks and execute arbitrary PHP code via a crafted serialized object in the _formvars form.

CVSS Base Scores

version 3.1