Out-of-Bounds Affecting python2.7 package, versions <2.7.7-1



    Attack Complexity High
    Confidentiality High
Expand this section
5.9 medium
Red Hat  medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN9-PYTHON27-306469
  • published 24 Aug 2017
  • disclosed 24 Aug 2017

How to fix?

Upgrade Debian:9 python2.7 to version 2.7.7-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python2.7 package and not the python2.7 package as distributed by Debian:9. See How to fix? for Debian:9 relevant fixed versions and status.

Array index error in the scanstring function in the _json module in Python 2.7 through 3.5 and simplejson before 2.6.1 allows context-dependent attackers to read arbitrary process memory via a negative index value in the idx argument to the raw_decode function.