CVE-2018-1061 Affecting python2.7 package, versions <2.7.13-2+deb9u3


0.0
high

Snyk CVSS

    Attack Complexity Low
    Availability High
Expand this section
NVD
7.5 high
Expand this section
SUSE
5.5 medium
Expand this section
Red Hat
6.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN9-PYTHON27-306482
  • published 19 Jun 2018
  • disclosed 19 Jun 2018

How to fix?

Upgrade Debian:9 python2.7 to version 2.7.13-2+deb9u3 or higher.

NVD Description

Note: Versions mentioned in the description apply to the upstream python2.7 package. See How to fix? for Debian:9 relevant versions.

python before versions 2.7.15, 3.4.9, 3.5.6rc1, 3.6.5rc1 and 3.7.0 is vulnerable to catastrophic backtracking in the difflib.IS_LINE_JUNK method. An attacker could use this flaw to cause denial of service.