Resource Management Errors Affecting python2.7 package, versions <2.7.3~rc1-1



    Attack Complexity Low
NVD  medium
Red Hat  medium
Expand this section
5.3 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN9-PYTHON27-306587
  • published 5 Oct 2012
  • disclosed 5 Oct 2012

How to fix?

Upgrade Debian:9 python2.7 to version 2.7.3~rc1-1 or higher.

NVD Description

Note: Versions mentioned in the description apply to the upstream python2.7 package. See How to fix? for Debian:9 relevant versions. in SimpleXMLRPCServer in Python before 2.6.8, 2.7.x before 2.7.3, 3.x before 3.1.5, and 3.2.x before 3.2.3 allows remote attackers to cause a denial of service (infinite loop and CPU consumption) via an XML-RPC POST request that contains a smaller amount of data than specified by the Content-Length header.