Cross-site Scripting (XSS) Affecting python2.7 package, versions <2.7.13-2+deb9u5


0.0
medium

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Scope Changed
Expand this section
NVD
6.1 medium
Expand this section
SUSE
5.4 medium
Expand this section
Red Hat
6.1 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN9-PYTHON27-469421
  • published 28 Sep 2019
  • disclosed 28 Sep 2019

How to fix?

Upgrade Debian:9 python2.7 to version 2.7.13-2+deb9u5 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python2.7 package and not the python2.7 package as distributed by Debian:9. See How to fix? for Debian:9 relevant fixed versions and status.

The documentation XML-RPC server in Python through 2.7.16, 3.x through 3.6.9, and 3.7.x through 3.7.4 has XSS via the server_title field. This occurs in Lib/DocXMLRPCServer.py in Python 2.x, and in Lib/xmlrpc/server.py in Python 3.x. If set_server_title is called with untrusted input, arbitrary JavaScript can be delivered to clients that visit the http URL for this server.