Insufficiently Protected Credentials Affecting python3.5 package, versions <3.5.3-1+deb9u2


0.0
critical

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Integrity High
    Availability High
Expand this section
SUSE
9.8 critical
Expand this section
NVD
9.8 critical
Expand this section
RHEL
9.8 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN9-PYTHON35-584435
  • published 7 Jun 2019
  • disclosed 7 Jun 2019

How to fix?

Upgrade Debian:9 python3.5 to version 3.5.3-1+deb9u2 or higher.

NVD Description

Note: Versions mentioned in the description apply to the upstream python3.5 package. See How to fix? for Debian:9 relevant versions.

A security regression of CVE-2019-9636 was discovered in python since commit d537ab0ff9767ef024f26246899728f0116b1ec3 affecting versions 2.7, 3.5, 3.6, 3.7 and from v3.8.0a4 through v3.8.0b1, which still allows an attacker to exploit CVE-2019-9636 by abusing the user and password parts of a URL. When an application parses user-supplied URLs to store cookies, authentication credentials, or other kind of information, it is possible for an attacker to provide specially crafted URLs to make the application locate host-related information (e.g. cookies, authentication data) and send them to a different host than where it should, unlike if the URLs had been correctly parsed. The result of an attack may vary based on the application.