Use of Externally-Controlled Format String Affecting ruby2.3 package, versions <2.3.3-1+deb9u2


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
9.72% (96th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-RUBY23-308535
  • published15 Sept 2017
  • disclosed15 Sept 2017

Introduced: 15 Sep 2017

CVE-2017-0898  (opens in a new tab)
CWE-134  (opens in a new tab)

How to fix?

Upgrade Debian:9 ruby2.3 to version 2.3.3-1+deb9u2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby2.3 package and not the ruby2.3 package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

Ruby before 2.4.2, 2.3.5, and 2.2.8 is vulnerable to a malicious format string which contains a precious specifier (*) with a huge minus value. Such situation can lead to a buffer overrun, resulting in a heap memory corruption or an information disclosure from the heap.