Link Following Affecting ruby2.3 package, versions <2.3.3-1+deb9u3


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
4.91% (92nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-RUBY23-308551
  • published13 Mar 2018
  • disclosed13 Mar 2018

Introduced: 13 Mar 2018

CVE-2018-1000073  (opens in a new tab)
CWE-59  (opens in a new tab)

How to fix?

Upgrade Debian:9 ruby2.3 to version 2.3.3-1+deb9u3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby2.3 package and not the ruby2.3 package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Directory Traversal vulnerability in install_location function of package.rb that can result in path traversal when writing to a symlinked basedir outside of the root. This vulnerability appears to have been fixed in 2.7.6.