Improper Input Validation Affecting ruby2.3 package, versions <2.3.3-1+deb9u1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
8.49% (95th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-RUBY23-308567
  • published31 Aug 2017
  • disclosed31 Aug 2017

Introduced: 31 Aug 2017

CVE-2017-0900  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:9 ruby2.3 to version 2.3.3-1+deb9u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby2.3 package and not the ruby2.3 package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

RubyGems version 2.6.12 and earlier is vulnerable to maliciously crafted gem specifications to cause a denial of service attack against RubyGems clients who have issued a query command.