Out-of-Bounds Affecting ruby2.3 package, versions <2.3.3-1+deb9u2


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
7.73% (95th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-RUBY23-308599
  • published19 Sept 2017
  • disclosed19 Sept 2017

Introduced: 19 Sep 2017

CVE-2017-14033  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Debian:9 ruby2.3 to version 2.3.3-1+deb9u2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby2.3 package and not the ruby2.3 package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

The decode method in the OpenSSL::ASN1 module in Ruby before 2.2.8, 2.3.x before 2.3.5, and 2.4.x through 2.4.1 allows attackers to cause a denial of service (interpreter crash) via a crafted string.