Improper Input Validation Affecting ruby-json-jwt package, versions <1.6.2-1+deb9u2


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.26% (66th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-RUBYJSONJWT-483267
  • published12 Nov 2019
  • disclosed12 Nov 2019

Introduced: 12 Nov 2019

CVE-2019-18848  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:9 ruby-json-jwt to version 1.6.2-1+deb9u2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby-json-jwt package and not the ruby-json-jwt package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

The json-jwt gem before 1.11.0 for Ruby lacks an element count during the splitting of a JWE string.

CVSS Base Scores

version 3.1