Improper Input Validation Affecting ruby-ox package, versions <2.1.1-2+deb9u1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.71% (77th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-RUBYOX-283804
  • published27 Oct 2017
  • disclosed27 Oct 2017

Introduced: 27 Oct 2017

CVE-2017-15928  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:9 ruby-ox to version 2.1.1-2+deb9u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby-ox package and not the ruby-ox package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

In the Ox gem 2.8.0 for Ruby, the process crashes with a segmentation fault when a crafted input is supplied to parse_obj. NOTE: the vendor has stated "Ox should handle the error more gracefully" but has not confirmed a security implication.