Directory Traversal Affecting ruby-rack package, versions <1.4.1-2.1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.94% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-RUBYRACK-322210
  • published8 Feb 2013
  • disclosed8 Feb 2013

Introduced: 8 Feb 2013

CVE-2013-0262  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade Debian:9 ruby-rack to version 1.4.1-2.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby-rack package and not the ruby-rack package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

rack/file.rb (Rack::File) in Rack 1.5.x before 1.5.2 and 1.4.x before 1.4.5 allows attackers to access arbitrary files outside the intended root directory via a crafted PATH_INFO environment variable, probably a directory traversal vulnerability that is remotely exploitable, aka "symlink path traversals."

CVSS Base Scores

version 3.1