Out-of-bounds Read Affecting sane-backends package, versions <1.0.25-4.1+deb9u1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.01% (59th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-SANEBACKENDS-570281
  • published23 May 2020
  • disclosed24 Jun 2020

Introduced: 23 May 2020

CVE-2020-12863  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Debian:9 sane-backends to version 1.0.25-4.1+deb9u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream sane-backends package and not the sane-backends package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

An out-of-bounds read in SANE Backends before 1.0.30 may allow a malicious device connected to the same local network as the victim to read important information, such as the ASLR offsets of the program, aka GHSL-2020-083.

CVSS Base Scores

version 3.1