Arbitrary Code Injection Affecting shibboleth-sp2 package, versions <2.6.0+dfsg1-4+deb9u2


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.31% (69th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-SHIBBOLETHSP2-1088064
  • published22 Mar 2021
  • disclosed22 Mar 2021

Introduced: 22 Mar 2021

CVE-2021-28963  (opens in a new tab)
CWE-74  (opens in a new tab)

How to fix?

Upgrade Debian:9 shibboleth-sp2 to version 2.6.0+dfsg1-4+deb9u2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream shibboleth-sp2 package and not the shibboleth-sp2 package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

Shibboleth Service Provider before 3.2.1 allows content injection because template generation uses attacker-controlled parameters.

CVSS Base Scores

version 3.1