Improper Input Validation Affecting shibboleth-sp2 package, versions <2.5.3+dfsg-2


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.94% (78th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-SHIBBOLETHSP2-317678
  • published31 Mar 2015
  • disclosed31 Mar 2015

Introduced: 31 Mar 2015

CVE-2015-2684  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:9 shibboleth-sp2 to version 2.5.3+dfsg-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream shibboleth-sp2 package and not the shibboleth-sp2 package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

Shibboleth Service Provider (SP) before 2.5.4 allows remote authenticated users to cause a denial of service (crash) via a crafted SAML message.

CVSS Base Scores

version 3.1