CVE-2021-31215 Affecting slurm-llnl package, versions <16.05.9-1+deb9u5


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.9% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-SLURMLLNL-1292172
  • published13 May 2021
  • disclosed13 May 2021

Introduced: 13 May 2021

CVE-2021-31215  (opens in a new tab)

How to fix?

Upgrade Debian:9 slurm-llnl to version 16.05.9-1+deb9u5 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream slurm-llnl package and not the slurm-llnl package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

SchedMD Slurm before 20.02.7 and 20.03.x through 20.11.x before 20.11.7 allows remote code execution as SlurmUser because use of a PrologSlurmctld or EpilogSlurmctld script leads to environment mishandling.

CVSS Base Scores

version 3.1