Untrusted Search Path Affecting slurm-llnl package, versions <16.05.9-1+deb9u1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.58% (47th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-SLURMLLNL-299785
  • published1 Nov 2017
  • disclosed1 Nov 2017

Introduced: 1 Nov 2017

CVE-2017-15566  (opens in a new tab)
CWE-426  (opens in a new tab)

How to fix?

Upgrade Debian:9 slurm-llnl to version 16.05.9-1+deb9u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream slurm-llnl package and not the slurm-llnl package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

Insecure SPANK environment variable handling exists in SchedMD Slurm before 16.05.11, 17.x before 17.02.9, and 17.11.x before 17.11.0rc2, allowing privilege escalation to root during Prolog or Epilog execution.