Improper Authentication Affecting slurm-llnl package, versions <1.3.13-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.08% (61st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-SLURMLLNL-299794
  • published15 Jan 2009
  • disclosed15 Jan 2009

Introduced: 15 Jan 2009

CVE-2009-0128  (opens in a new tab)
CWE-287  (opens in a new tab)

How to fix?

Upgrade Debian:9 slurm-llnl to version 1.3.13-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream slurm-llnl package and not the slurm-llnl package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

plugins/crypto/openssl/crypto_openssl.c in Simple Linux Utility for Resource Management (aka SLURM or slurm-llnl) does not properly check the return value from the OpenSSL EVP_VerifyFinal function, which allows remote attackers to bypass validation of the certificate chain via a malformed SSL/TLS signature, a similar vulnerability to CVE-2008-5077.

CVSS Base Scores

version 3.1