CVE-2020-12693 Affecting slurm-llnl package, versions <16.05.9-1+deb9u5


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.31% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-SLURMLLNL-570179
  • published22 May 2020
  • disclosed21 May 2020

Introduced: 21 May 2020

CVE-2020-12693  (opens in a new tab)

How to fix?

Upgrade Debian:9 slurm-llnl to version 16.05.9-1+deb9u5 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream slurm-llnl package and not the slurm-llnl package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

Slurm 19.05.x before 19.05.7 and 20.02.x before 20.02.3, in the rare case where Message Aggregation is enabled, allows Authentication Bypass via an Alternate Path or Channel. A race condition allows a user to launch a process as an arbitrary user.

CVSS Base Scores

version 3.1