Improper Access Control Affecting subversion package, versions <1.9.4-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
6.81% (94th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-SUBVERSION-344328
  • published5 May 2016
  • disclosed5 May 2016

Introduced: 5 May 2016

CVE-2016-2167  (opens in a new tab)
CWE-284  (opens in a new tab)

How to fix?

Upgrade Debian:9 subversion to version 1.9.4-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream subversion package and not the subversion package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

The canonicalize_username function in svnserve/cyrus_auth.c in Apache Subversion before 1.8.16 and 1.9.x before 1.9.4, when Cyrus SASL authentication is used, allows remote attackers to authenticate and bypass intended access restrictions via a realm string that is a prefix of an expected repository realm string.

CVSS Base Scores

version 3.1