Improper Input Validation Affecting tigervnc package, versions <1.7.0+dfsg-7


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.61% (75th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-TIGERVNC-304253
  • published1 Apr 2017
  • disclosed1 Apr 2017

Introduced: 1 Apr 2017

CVE-2017-7394  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:9 tigervnc to version 1.7.0+dfsg-7 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tigervnc package and not the tigervnc package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

In TigerVNC 1.7.1 (SSecurityPlain.cxx SSecurityPlain::processMsg), unauthenticated users can crash the server by sending long usernames.