Information Exposure Affecting twig package, versions <1.24.0-2+deb9u1


Severity

Recommended
0.0
low
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.41% (69th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-TWIG-341366
  • published23 Mar 2019
  • disclosed23 Mar 2019

Introduced: 23 Mar 2019

CVE-2019-9942  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade Debian:9 twig to version 1.24.0-2+deb9u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream twig package and not the twig package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

A sandbox information disclosure exists in Twig before 1.38.0 and 2.x before 2.7.0 because, under some circumstances, it is possible to call the __toString() method on an object even if not allowed by the security policy in place.

CVSS Base Scores

version 3.1