Improper Input Validation Affecting udisks2 package, versions <2.1.8-1+deb9u1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.91% (59th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-UDISKS2-1767106
  • published26 Oct 2021
  • disclosed29 Nov 2021

Introduced: 26 Oct 2021

CVE-2021-3802  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:9 udisks2 to version 2.1.8-1+deb9u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream udisks2 package and not the udisks2 package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

A vulnerability found in udisks2. This flaw allows an attacker to input a specially crafted image file/USB leading to kernel panic. The highest threat from this vulnerability is to system availability.

CVSS Base Scores

version 3.1