Buffer Overflow Affecting weechat package, versions <1.6-1+deb9u3


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.1% (82nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-WEECHAT-560897
  • published21 Mar 2020
  • disclosed23 Mar 2020

Introduced: 21 Mar 2020

CVE-2020-9760  (opens in a new tab)
CWE-120  (opens in a new tab)

How to fix?

Upgrade Debian:9 weechat to version 1.6-1+deb9u3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream weechat package and not the weechat package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

An issue was discovered in WeeChat before 2.7.1 (0.3.4 to 2.7 are affected). When a new IRC message 005 is received with longer nick prefixes, a buffer overflow and possibly a crash can happen when a new mode is set for a nick.

CVSS Base Scores

version 3.1