Out-of-Bounds Affecting xdelta3 package, versions <3.0.8-dfsg-1.1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
4.16% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-XDELTA3-307434
  • published19 Apr 2016
  • disclosed19 Apr 2016

Introduced: 19 Apr 2016

CVE-2014-9765  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Debian:9 xdelta3 to version 3.0.8-dfsg-1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream xdelta3 package and not the xdelta3 package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

Buffer overflow in the main_get_appheader function in xdelta3-main.h in xdelta3 before 3.0.9 allows remote attackers to execute arbitrary code via a crafted input file.

CVSS Base Scores

version 3.1