Arbitrary Command Injection Affecting xdg-utils package, versions <1.1.0~rc1+git20111210-7.4


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.21% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-XDGUTILS-309970
  • published27 Jun 2018
  • disclosed2 Jun 2021

Introduced: 27 Jun 2018

CVE-2015-1877  (opens in a new tab)
CWE-77  (opens in a new tab)

How to fix?

Upgrade Debian:9 xdg-utils to version 1.1.0~rc1+git20111210-7.4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream xdg-utils package and not the xdg-utils package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

The open_generic_xdg_mime function in xdg-open in xdg-utils 1.1.0 rc1 in Debian, when using dash, does not properly handle local variables, which allows remote attackers to execute arbitrary commands via a crafted file.

CVSS Base Scores

version 3.1