CVE-2018-6540 Affecting zziplib package, versions <0.13.62-3.2~deb9u1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.26% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-ZZIPLIB-305284
  • published2 Feb 2018
  • disclosed2 Feb 2018

Introduced: 2 Feb 2018

CVE-2018-6540  (opens in a new tab)

How to fix?

Upgrade Debian:9 zziplib to version 0.13.62-3.2~deb9u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream zziplib package and not the zziplib package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

In ZZIPlib 0.13.67, there is a bus error caused by loading of a misaligned address in the zzip_disk_findfirst function of zzip/mmapped.c. Remote attackers could leverage this vulnerability to cause a denial of service via a crafted zip file.