Symlink Following Affecting apptainer package, versions <1.4.5-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.23% (13th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-APPTAINER-14162351
  • published3 Dec 2025
  • disclosed2 Dec 2025

Introduced: 2 Dec 2025

CVE-2025-65105  (opens in a new tab)
CWE-61  (opens in a new tab)
CWE-706  (opens in a new tab)

How to fix?

Upgrade Debian:unstable apptainer to version 1.4.5-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream apptainer package and not the apptainer package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

Apptainer is an open source container platform. In Apptainer versions less than 1.4.5, a container can disable two of the forms of the little used --security option, in particular the forms --security=apparmor:<profile> and --security=selinux:<label> which otherwise put restrictions on operations that containers can do. The --security option has always been mentioned in Apptainer documentation as being a feature for the root user, although these forms do also work for unprivileged users on systems where the corresponding feature is enabled. Apparmor is enabled by default on Debian-based distributions and SElinux is enabled by default on RHEL-based distributions, but on SUSE it depends on the distribution version. This vulnerability is fixed in 1.4.5.

CVSS Base Scores

version 3.1