Buffer Overflow Affecting bird2 package, versions <2.0.6-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.15% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-BIRD2-467093
  • published10 Sept 2019
  • disclosed9 Sept 2019

Introduced: 9 Sep 2019

CVE-2019-16159  (opens in a new tab)
CWE-120  (opens in a new tab)

How to fix?

Upgrade Debian:unstable bird2 to version 2.0.6-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream bird2 package and not the bird2 package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

BIRD Internet Routing Daemon 1.6.x through 1.6.7 and 2.x through 2.0.5 has a stack-based buffer overflow. The BGP daemon's support for RFC 8203 administrative shutdown communication messages included an incorrect logical expression when checking the validity of an input message. Sending a shutdown communication with a sufficient message length causes a four-byte overflow to occur while processing the message, where two of the overflow bytes are attacker-controlled and two are fixed.

CVSS Base Scores

version 3.1