Arbitrary Command Injection Affecting cimg package, versions <2.3.6+dfsg-1


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
4.97% (92nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-CIMG-455441
  • published25 Jul 2019
  • disclosed25 Jul 2019

Introduced: 25 Jul 2019

CVE-2019-1010174  (opens in a new tab)
CWE-77  (opens in a new tab)

How to fix?

Upgrade Debian:unstable cimg to version 2.3.6+dfsg-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cimg package and not the cimg package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

CImg The CImg Library v.2.3.3 and earlier is affected by: command injection. The impact is: RCE. The component is: load_network() function. The attack vector is: Loading an image from a user-controllable url can lead to command injection, because no string sanitization is done on the url. The fixed version is: v.2.3.4.

CVSS Base Scores

version 3.1