XML Injection Affecting cmark-gfm package, versions <0.29.0.gfm.13-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.72% (50th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-CMARKGFM-3257764
  • published31 Jan 2023
  • disclosed24 Jan 2023

Introduced: 24 Jan 2023

CVE-2023-22485  (opens in a new tab)
CWE-91  (opens in a new tab)

How to fix?

Upgrade Debian:unstable cmark-gfm to version 0.29.0.gfm.13-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cmark-gfm package and not the cmark-gfm package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

cmark-gfm is GitHub's fork of cmark, a CommonMark parsing and rendering library and program in C. In versions prior 0.29.0.gfm.7, a crafted markdown document can trigger an out-of-bounds read in the validate_protocol function. We believe this bug is harmless in practice, because the out-of-bounds read accesses malloc metadata without causing any visible damage.This vulnerability has been patched in 0.29.0.gfm.7.

CVSS Base Scores

version 3.1