Race Condition Affecting devscripts package, versions <2.12.2


Severity

Recommended
0.0
low
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.27% (19th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-DEVSCRIPTS-293281
  • published1 Oct 2012
  • disclosed1 Oct 2012

Introduced: 1 Oct 2012

CVE-2012-3500  (opens in a new tab)
CWE-362  (opens in a new tab)

How to fix?

Upgrade Debian:unstable devscripts to version 2.12.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream devscripts package and not the devscripts package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

scripts/annotate-output.sh in devscripts before 2.12.2, as used in rpmdevtools before 8.3, allows local users to modify arbitrary files via a symlink attack on the temporary (1) standard output or (2) standard error output file.

CVSS Base Scores

version 3.1