Improper Verification of Cryptographic Signature Affecting electrum package, versions <4.7.2+dfsg-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.11% (2nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-ELECTRUM-21762770
  • published28 Oct 2026
  • disclosed27 Oct 2026

Introduced: 27 Oct 2026

NewCVE-2026-117602  (opens in a new tab)
CWE-347  (opens in a new tab)

How to fix?

Upgrade Debian:unstable electrum to version 4.7.2+dfsg-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream electrum package and not the electrum package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

Electrum 4.6.0 before 4.7.2 contains an authorization bypass in the external plugin loader, which executes a plugin's init.py module when the plugin is marked enabled in the config file, without verifying its plugin-password signature. A rogue local process with write access to the Electrum data directory can place plugin code in the plugins/ folder and mark it enabled, causing arbitrary code execution inside the Electrum process.

CVSS Base Scores

version 3.1