Time-of-check Time-of-use (TOCTOU) Affecting electrum package, versions <4.8.1+dfsg-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.19% (10th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-ELECTRUM-21762773
  • published28 Oct 2026
  • disclosed27 Oct 2026

Introduced: 27 Oct 2026

NewCVE-2026-117603  (opens in a new tab)
CWE-367  (opens in a new tab)

How to fix?

Upgrade Debian:unstable electrum to version 4.8.1+dfsg-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream electrum package and not the electrum package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

Electrum before 4.7.2 contains a spending limit bypass vulnerability in the Nostr Wallet Connect plugin that allows malicious NWC clients to exceed daily_limit_sat by exploiting non-atomic budget checks and millisatoshi truncation. Attackers can send concurrent pay_invoice requests that pass budget_allows_spend() before add_to_budget() runs, or repeatedly pay msat amounts that are floored to whole satoshis, to drain funds beyond the limit.

CVSS Base Scores

version 3.1