Out-of-bounds Read Affecting gfs2-utils package, versions <3.6.1-2


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.11% (2nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-GFS2UTILS-19518411
  • published4 Sept 2026
  • disclosed3 Sept 2026

Introduced: 3 Sep 2026

CVE-2026-71222  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Debian:unstable gfs2-utils to version 3.6.1-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gfs2-utils package and not the gfs2-utils package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

A heap out-of-bounds read vulnerability was found in gfs2-utils. The ea_num_ptrs field from on-disk extended attribute metadata is consumed without bounds validation, causing a heap buffer over-read that may disclose sensitive memory contents or cause a crash when processing crafted GFS2 filesystem images.

CVSS Base Scores

version 3.1